PDA

View Full Version : Fuel System Electric Problem 2005 Multistrata



ROB-IN-US-VA
09.10.2015, 05:04 PM
I went out for a ride 2 weeks ago and the bike just quit - like someone turned off the key. That spells electrical to me - fuel pump is not priming when the key is turned. Relay and fuses are good. Shop manual on order from New Zealand. Looking for test points on harness or a schematic.
Been off the bike for 3 weeks now - anxious to fix this and get in some rides before winter.

DrD
09.10.2015, 05:14 PM
Have you checked known weak spots like sidestand cut-out switch and engine kill button and associated wiring
Sounds like something quite basic in the electrics.

Derek
09.10.2015, 05:46 PM
The side stand switch won't stop the pump from running when the bike is in neutral. Check for 12V at pin 1 of the fuel pump connector. Easiest way is to connect a test lamp across pins 1 and 2 of the loom connector. It should light up for a few seconds at switch on. If not the problem is with the relay/wiring loom. If yes then the problem is with the fuel pump or the wiring to it from the connector through the tank flange. Breakages of the wires through the flange is a known failure point for this model. http://www.multistrada.net/forum/viewtopic.php?t=31574&highlight=tank+flange

ROB-IN-US-VA
09.10.2015, 05:49 PM
I will check the side stand switch - was replaced once before. The starter cranks, I've got spark, new battery - fully charged, the only system left is fuel. I really don't want to spend $1000 USD on a new fuel pump assembly - taking the tank apart will be enough of a hassle.
If the side stand switch is bad would the starter crank??

Derek
09.10.2015, 08:32 PM
If you ’ve got sparks there is also power going to the fuel pump. The coils and pump are both switched from the pump relay. Looks like your problem lies with the pump, its connector or wires.

duccout
27.10.2015, 03:48 PM
Sounds like the fuel pump relay to me!